(ZW3D broken face 3D) Please help me fix the above error

132A 132B.PNG 132C 132D 132E

Hi there,

Looks like imported geometry to me
So, a wild guess to come up with a solution.
Try importing with part settings on a tolerance of 0.2 mm, instead if the default 0.01
When successful you can set the tolerance back to default and start modeling.
Again, it is a wild guess, but it may help

Good luck,

1 Like

Hi KsT,
Yeap, welcome. Bit of a rough intro though!!!

everything is a wild guess with scant info like this.
Have you tried different import settings?
Have you run Heal Analysis/Tools?
When zoomed in edges can get ragged - View/Refine Facets might improve the look!

To help, you need to explain where the geometry came fro, what is the exact problem, what error reports do you see etc.

Cheers - Paul

1 Like

Thank’s Luurt.
I will try.

Thank’s Cheers - Paul
“Have you tried different import settings?
Have you run Heal Analysis/Tools?”
Can you guide me in detail.

Hi KsT,
are you new to ZW?
You are going to have to do some self learning.

Off course there is HELP which ofr the most part is good.
But there is another resource you might have missed.
There are no short cuts - follow the processes in there.
The sample files are already installed and you can do the exercises.
There is a lot of info on dealing with poor imported geometry as that is what ZW does especially well.
The repair tools are great once you know what use.
Surfs up here this weekend so I am gone. :surfing_man:
Cheers - Paul

Yes I am new to ZW3D.
I have read theTraining Manuals.
I am having the above problem needing help from you.
This 3D surface makes it difficult for CNC programming.
More machining time!
More polishing time!

Hi KsT, once you have read the training manuals and still have healing issues, then if you send me the file in ZW format and the original format you opened it from, then I can repair it for you. alan@cadcam-grafix.com.
I found this sort of issues when importing IGES format.


I send PRODUCT4.Z3 file to zw3dforum.
Please help me fix it!
Thank Alan.
Thank’s All.
PRODUCT4.Z3 (1005.3 KB)

Hi KsT, from seeing the file you sent, it looks like you designed this part and it was not imported.
Your process caused you the issues you had. Fixed it for you. Had to save it in a NEUTRAL file because you are not using ZW2020 version.
I also saved it as a PARASOLIDPRODUCT4-2020.x_t (303.2 KB) PRODUCT4-2020.zip (193.1 KB) file in case.
PRODUCT4-STEP.stp (523.6 KB)

Hi Alan,
could you also post your 2020 Model -
We are all curious what you did?
Cheers - Paul

Good day!
Thank’s Alan and Cheers - Paul

We are all curious what you did?

PRODUCT4-2020.Z3 (2.5 MB)

I have loaded the 2020 file.
I had to rebuild the Hook Rib because it was causing the issues.
If you start the history regen you will see the process that caused the issues.
When I first opened the original modeled part, I did not have the same ugly surface issues as KsT, the surfaces were actually looking good enough to me that I would have used the model as is if I didn’t know there was an issue with it( Probably would have found out later during the machining process), but I dont have machining capability with my package.

1 Like