Strange reference calculation

When I select a surface for reference, I got this result. The edge isn’t followed and a small gap remains. Pict 1 selection of surface.
Pict 2 result.
Pict 3 zoomed in on gap. Ref doesn’t follow the edge.
Anybody an idea how to solve.
Made with zw3d2023.

PIC 1:

PIC 2:

PIC 3:


Hi Bli,
Looks like you have planar cut on an existing shape?
The initial shape may be a bit loos and have poor geometry.
Try a heal analysis before the slice.
If it has problems, run a heal and see if it is resolved.
If you have generated the shape, you can set the tolerance higher before you start and see if that closes the gaps.
Once edges are gapless the reference edges should work.
Cheer - Paul

Hi Cowboy99,

As you mentioned, there was a small mismatch. It was just at that location. I have changed my skeleton part and switched to 2023SP1. The problem seems to be solved.
Thanks for your assistance.
Kind regards, Roland

Oeps. To enthusiast. Not solved yet.

HI BliTec:
With SP1?

Not 2023x?

Can you share your files?

The latest version just released last week.
I think it’s 2023x, instead of SP1

HI BliTec:
Now there is no SP, only version x,

The version you are using has been updated many times.


I’m working with an assembly where the parts have a reference with a skeleton part by External Geom Copy, but the link in the parts to the skeleton get lost when I update the skeleton.
I have checked it with a packed file, but here also the same problem.
I don’t know why, but it is frustrating. Currently, I don’t have time to figure it out because I’m running behind schedule already due to other zw3d issues.


HI BliTec:
No wonder for you. I don’t know how to help you!

Hi Bli,
Using External Geometry Copy is not good modeling practice as the update procedure is not designed for that.
Much better to use Assembly Reference Tools and pull the assoicative copy of the Skeleton into each part that needs it.
This is designed to update any changes in the Skeleton Part.
Cheers - Paul

Hi Paul,

In my case, it doesn’t matter which method you use. zw3d doesn’t calculate it on the right way.
I have experienced it also in your method of referencing.

The method you mentioned was the way you had to do it up to 2023. That’s also the way I did it until now. Zw3d 2023 has this new feature, just for working with skeletons.

See YouTube: ZW3D 2023 (CAD) : Geometry Publish & Copy - YouTube

I have set up a new part according to the new feature. Did a first a test, and it worked very well.
Here is the file of the test parts in zip. (659.3 KB)

So, I decided to do my new model according to the new method.

I have experienced another problem with this method, my parts have lost the reference link to the skeleton. I was unable to edit the feature and to restore the link. It’s now sent to zw3d to analyze it.

Regards, Roland

Hi Roland,
I had not seen the publish option.
This looks like the same external assembly reference process with some automated shortcuts.
It adds another layer of complexity perhaps compared to the old way which also has its limitations.
BUT it still needs to work all the time - right!
Cheers - Paul