Solid disappeared from view due to scaling down

Hello .
Yesterday I was working on a mold for a solid part I have. My work was OK. No problem with visibility of the part using Zoom All function.
I have created project,oriented it, analysed it crated parting lines…and there I ran into difficulties(I am only learning)…so after all I erased all I have done, used Encapsulate history, so only the Solid and the project was left. Saved it, exited the application.
Today, then I loaded the part, the part was not visible. The history manager shows there is solid, so I started to zoom in(as something similar happened to me before) and zoom in and zoom in and the part finally came to view…
So I used “Zoom all” command(to minimize the part again) and using mouse window function and “ALL” in the entity filter, I tried to erase everything around the triad(where the part was minimized)…but it did not help. The part is just disappearing when “Zoom All” function is executed.
What can be wrong???
Thank you

Hi Resu,
no idea what has gone wrong.
Your backup file is a ZW file with bak added to the end of it.
You rename the file and open that to see if your original file is still as you need it.

Encapsulate is normally very robust.

The only other thing that can happen is you accidentally saved the file to a different location! I have been caught by that problem before.
Look in the default location that ZW is using.


Hi Resu,

Try using the command “Recover Faces”.
It should help in your case…

Nope…did not help. The message Part size should not exceed 500 000 in relative to active tolerance of .0005".
Consider to undoing the oversized feature and increase active tolerance

In Root Object level, you can Try Fix Objects and Clean File.

BUT I think you have a corrupt file for what ever reason.

Easy solution,
Create a fresh file/z3prt -
Re import
Make sure the Import is non associative.
Do any healing , gap filling, etc.
When you have a clean error free solid - Encapsulate.
Save this file as you start model.
New part.
Insert the shape and position as you want it.
Merge Component so it is now an editable shape.
Copy the edit history for the original model and paste into this one.
Step through each feature and re select target elements.
Run the Clean and Fix tools - Save

Did I ask this already - are you using the Play Controls at the bottom of the History Manager?
If not, expand them and learn their functions.
It will help a lot.

Cheers -Paul

Today, 3-10-2021.
I have received slick solution to above mentioned problem from another source:
Make a copy of the file, in case something goes wrong.
Shut of visibility of the geometry you want to keep(using blank or clicking on the little window in front of the shape/geometry in the history tree)…
Now click on the Erase Icon on top of the geometry creation window (it is like 2nd or 3rd to the right from the exit icon). (This erase icon looks like the end of the yellow pencil with red rubber eraser).
Little widow frame comes upon left side prompting for entity (you want to erase)…Right click on drawing area and from the menu select “select all”. It will select all what is “visible” on the screen(even though it is obviously not visible - probably due to the size and scale factor) and then click OK. It will erase all these entities, which caused the part to disappear due to screen scale.
Now the “Zoom All” command works and your part will zoom all across the screen.

Hi Resu,
The Blank $ Pick All solution assumes(you can tell by looking at the extent value next to the lower left triad) the view extent is the problem hence it works. You can also do the same process with in a sketch to find invisible ‘ghost’ elements and delete them.

Or you can manually set the view extent to close to your part size - see the View commands.

Cheers - Paul