Regen error "Traversal of recursive object network aborted."

Can some development experts here help me.
What does it mean when I regen my Z3PRT (sheetmetal) and it needed very long and at the end (several minutes) I get the message log “Traversal of recursive object network aborted.”
Is it like a crc?
When I try to run Clean file or fix objects I get never ending run. I let it run several hours without an end.
How I can I find out what’s causing the issue?
I tried to delete step by step all the features, but that doesn’t fix it.

HI caddie:
You can try to copy and paste all the problematic modeling features into a new file。


1 Like

Hi Caddie

I had a similar regeneration issue in an earlier version that led back to where I was storing the files and the file structure.
Paul and Cowboy99 suggested that all files need to be a single folder and preferably not too far down the file tree.
I was trying to use a file structure that was stored on a NAS and buried in multiple layers of folders. When I tried to regenerate or open the file, i would get a similar error message.
After moving all the files into a single folder and doing the drawing on the local hard drive, the problem has not returned.
I just use a back up routine to copy the files onto a NAS now for backup.
I was hoping this rather simple pathing issue would be resolved in this version, but possibly not.


1 Like

HI Russty:
The packaging of the new version is very good!


Thank you Ken for that hint.
I faced similar issue storing everything through an shared drive from my NAS.
It was really challenging to copy the files to a local drive because the files ate having the NAS unc path stored in their dependencies etc…
But again i faced this issue with “Traversal of recursive object network aborted.” on the local drive.
I discovered a reference on a hem flange on sketch caused this. So trying to unbend it, the location of the sktech get lost. By using a plane as reference a relocate it in the sketch fixed that. Then the utility clean file function does no more freezes ZW3D and fixed the z3prt part.
But anyway, what does that
“Traversal of recursive object network aborted.” really means?
Is it a timeout of the network shared unc path which is recursive. But why recursive?

Hi Caddie

Not completely sure what the error message is, but would suggest that the network times out when trying to find all the different parts as the program calls them.

I found with my models, when I started a new one it would work fine until I put in a number of parts/components into an assembly. If I then went and made a change to one of the parts, either through the assembly, or opening the part and saving, it would cause the problem.

The number of the parts varied so there was not definitive number before problems. I did notice though if I was working on the local hard drive with a multi level file structure I could put in more parts before the error.

But as soon as I tried to do it on the network, the problem started and was not recoverable. I recreated quite a few assemblies before Cowboy99 sorted me out on the file structure issue. Does not seem to have an issue, although I would love to be able to have a more friendly file structure.

Coming from Inventor I could create a part in a separate file folder, and then just reuse the top model for other drawings, provided a mapped file path was in inventor. Was great, I could easily work on the hydraulic pump for example in its own folder and then when I wanted to include it I had a good idea of where I had to look.

I am out of that line of work now and just playing around so it doesn’t impact greatly on me anymore.

Hope you can find a good solution for your problem.

Hi Russty:
Thank you for sharing, and wish you a pleasant journey!