Oblong shapes & crashes

Hi everybody,

I am the only one having constant crash when using oblong shape in sketches?

The probability of crash when I start using them rise to 100%, its only a matter of time once I inserted one. Some times, I can crash 10 times in a single minutes, restarting ZW3D and trying back my inputs, I literally have to save after EACH successful clicks.
The software will usually crash when an entity I am about to select start to highlight, whether or not its an entity belonging to the oblong, the the rectangle it is constrained in, a dimension I want to edit or a constrain symbol I want to delete…

Once I leave the sketch, I can do anything (extrude, assemble, mechanical constrains…) with no problem. I can regen indefinitely, putting my dimension into equation and piloting them outside of the sketch. The issues vanish.

This have been a disaster since v2022. The silent update didn’t changed much about this.

EDIT: I have also noticed that ZW3D automatically add odd constrains when inserting oblong shapes vertically or horizontally. One of the extremities’ arc will have a VERTICAL or HORIZONTAL constrain whose symbol is grayed out.


Hi Nicolas,
can you provide a screen shot?
I have not had any such problem.
Cheers - Paul


Uploading: 1a.jpg… Uploading: 1b.jpg…

Uploading: 2a.jpg... 3

Uploading: 3.jpg...

Uploading: 4a.jpg...
4b 4c 4d 4f 4g 4h

There you go, I have quite the collection ^^.

Hi Nicolas,
very strange,.
Can I suggest you refresh your User folder using User Folder Manager amd see what happens.
Cheers - Paul

Hi Paul,
Sorry for the delay, I am back from holidays.
I have proceeded. I will let the week pass, and see what happen.


1 Like

HI Nicolas_TR:

First back up the license file;
C:\Users\ user :smile:name \AppData\Roaming\ZWSOFT\ZW3D\ZW3D 2022\custom\license.xml

Then proceed as follows. If it still doesn’t work, you can install TODESK, contact me, and I’ll try it for you.



Thanks Liangfen,

I had already do the cleanning operations this monday, except the licence backup bit you just mentionned :sweat:.
If, today, I happen to go into that directory, there is no licence.xml. Nowhere in my drives even, although I have some LicenceCsy in the setups folders.
We use GPsoftware USB dongle licence, if it explain anything.

As for the initial issue, now I will let the time pass a bit and draw stuff here and there, to check if the clearing fix saves me.


HI Nicolas_TR:

Does your current problem still exist?

license.xml 文件是KEY激活的才有,你的硬件狗应该没有这文件。
The license.xml file is only activated by KEY, and your dongle should not have this file.

Hi liangfen,

I have had a another crash yesterday.
I will keep monitoring as I don’t draw much lately.


Yep, it keeps crashing, even for trivial thing.

As I messed up with v2022X attempt, I even reinstalled v2022 last week.

Maybe it come from my computer. Its a Thinkstation P330 with Quadro P4000. I have the latest Lenovo recommended drivers except for the last BIOS flash. I can try this…


Ah, today is a first, it even crashed on editing an oblong shape I made myself (line, arc, line arc, tangent constraints…).
I was working on some folded metal part, I just created a flange on one of its edge.
I created a sketch to pierce an oblong hole on this flange, I even picked a datum plane so to not pre-constraint my sketch on some variable shape.
I started drawing my oblong, I literally constrained nothing of it to any entity of my folded part in the background.
I was either adding the last tangent constraint or equal radius for both arc, and crash…

And lately, crash report crash itself ALL the times, I have to resend any reports twice. And when I am typing this message in the meantime, when the “resend pop-up message” show up, a n key stroke accidentally valid “no”. So no report today… (#mylifesucks)

EDIT 1 :
Again, it only happen since v2022 is installed, on the same computer, on the same OS.

Bha, I just reopen the file, reopen the part, the sketch, I click “dimensionning”, I select 1 arc center, and I move toward the flange edge to set the hole offset, and immediate crash.
I am back like before the holidays when I needed to save after EVERY input…


Here you go,2021-09-21 09-37-03.zip (2.6 MB)
I know you don’t like video file on your forum, but I needed to show/share this frustration as I am about to establish new guiness crash speed record. Feel free to delete the file if you wish.

Funny thing, the very first time I opened OBS this morning (you don’t see it, its on my left monitor), and tried to record, sketching actually worked (though it could have crashed later on). I though my computer was trolling me at this point, so closed OBS, retried, crashed again, restarted OBS, and was actually able to record the crash.

And this oblong shape you saw (in the crashing shetch) wasn’t even made using the “oblong shape” function.
I literally never have any crashes but when working IN sketches that contain at least ONE oblong shape. It doesn’t make any sense…
I am not even 2 hours yet at work today, and I already don’t have enough fingers on my body to count how many crashes I got, just for this part, that need to be done regardless.


Sorry you are experiencing so much pain. Soul destroying stuff.
Looks to me like you have a corrupt file.
It may only be one object that is corrupt but it i in memory.

What happens if you run the Fix Objects and Clean File?
An option is to run Separate File mode which is a bit is a change but I find it limits corruption risk massively and is also much faster saving etc.
Bit of a journey figuring things out but worth it IMO.
You can just create a single folder and separate to that.
My recommendation is you do any name changes in the multi object file first.

Cheers Paul