Make imported files take my template

Hello everyone!
I am working with one object per file, I have my .Z3PRT and .Z3ASM templates, I have added user parameters to fill the title block of the drawing.
If I create new files with my templates I have no problem, but if I import, for example, some assembly, none of my user parameters are shown in the imported files.
I already have the .Z3PRT and .Z3ASM files added to be the default template. I attach a video showing what I’m talking about.
I think the import takes the empty default ZW3D file, does anyone know how to modify that file?
Could someone help me with this issue please?

Thanks. Cheers!

HI cale99:
I guess what programmers think is to create a new file using the template, and then import the third-party format, so that the attributes in the template are valid.
Like you now this operation, the default call or the system blank template!

Hi Cale,
easy as to remedy.
I’m wondering if simply opening the assembly the way you did is the problem.
If you open a new assembly file then import the assembly it should be fine.

But on the bottom right corner of the User Attributes page are the Export/Import Attributes buttons.
You can export your standard attributes from the good file. Then Import it into the Import file and get on with it real fast.
If updating older files, delete the original attributes before importing new ones - they just add on the end.

Cheers - Paul

1 Like

Hi LiangFen, hi Cowboy.

I already tried to import from the template, but only the attributes are placed at the top level of the assembly, the subassemblies and components are still blank.
I’ll still use the option to import the attributes to each file, I just wanted to see if I could avoid that part.
Thanks to both.


1 Like

Hi cale99:

I tried to export STP with attributes with ZW3D, and then import it directly again. Its attributes are still there.
零件001.stp (8.2 KB)

After my test, the version above 2021 is only supported!!


1 Like

Hi Liangfen.

It worked for me! The bad thing is that the files that are shared with me do not have attributes, but I am going to review it. Thank you so much!


1 Like