How to expand error message dialog boxes

Hi Peoples
I am slowly getting back into this after a long break.
I created an equation set and made some calculations etc.
Then build up some parts and all was good.
Then I made a change to one of the parts and now I am getting this message whenever I close that part, sketch or hit the regenerate button.
The problem I have is it does not give me enough information to go and see where it reckons the problem is.
As you can see from the image of the dialog box, it sort of cuts off before it gets to which variable is the issue.
How do I resize this dialog box, or does this message get written in a file somewhere I can go have a look at.

HI Russty:

You can choose this mode to try!

Hi Mr Zhang
Thank you for your suggestion. Unfortunately this did not fix the issue.
Is there anyway to get the dialog box to expand so the whole message appears so I can see which equation in particular has an issue?

HI Russty:

If you can upload the problem file, let us have a look!

Hi Ken Russ and Mr Zhang, I have been getting this same error for a long time but ignore it because I know there are no equations in the file.
A solution would be GREAT !


HI AlanDeKlerk:

I recommend the design of single file mode, that is, to open a single file without . Z3 mode


From this, which components are related?


Maybe there can be more error data given into the “Error pop-up window”:

Also, I believe there is an “error troubleshooting manager” (and I insist on the " " , no idea how it is called).

One time I required a technician intervention, about a 3D/2D issue (graphic entities from the 3D model not showing up in 2D projections, or unable to be selected).
The guy went into some manager where he could find all the entities references (edges or vertices numbers), to try and find the geometry that caused problem.
I don’t believe it was the assembly “Link Manager”, but I am not sure. I wish I paid more attention to where he opened it (should have run OBS studio, darn it!).

I also wish I could trouble shoot some errors myself. Sometimes, you have errors likes “Problem with entity 80225453” and you have no idea what entity 80225453 is (an edge, a vertex, a custom datum? …) and what you can do about that…


Hi Mr Zhang
Sorry, I have back tracked through the model and ended up rebuilding it. The issue is not there anymore.
This was how it worked originally,
The issue only started after I went in to make some modifications to the model.
I have the equation set in the same project file. Have named all the files without spaces and kept them in the same directory.
Willl just have to keep an eye on it and come back to you if the problem reemerges.

HI Russty:

This is good news. I hope I can catch this problem next time!

Hi Ken,
sounds like the problem was a modelling error.
It is common to occasionally have a model that is like this. Almost always it can be cured by a more refined modelling approach. I find I can usually improve a model simplicity and reliability a lot second time around and it doesn’t take as long as the first time.

Re expanding the error window - that should not be a problem. You should be able to dock it somewhere. I have taken to putting it above my history tree which means I see the errors sooner rather than at the bottom of the screen.
Cheers - Paul.

HI Cowboy99:

Can I see your version information?

Hi Cowboy
I think the problem arose after the first modeling of the shape.
Then I went back and made some subtle changes within the model, e.g. added two flanges.
Then I noticed this would not work so went back in and removed the flanges. The only difference between the original and update was the original is completely driven from the equation set and the mods were directly editing and measured etc.
Will just have to see how this goes into the future.
I have also just ordered the 2022 version from my local supplier. Hopefully this will be a better and stable platform now.

I’m not at that PC for a several days.
And the reason you want to see that info?
Cheers - Paul

HI Cowboy99:

I see your message window with the word info. I’m curious about your installation package version!

HI Cowboy99:

I’m just curious about why you enable debugging mode by default (with advanced message content). Now I’ve found the reason.